Vulnerability · Published Apr 9, 2026 · Assigned by apache

CVE-2026-32990Apache Tomcat: Fix for CVE-2025-66614 is incomplete

Medium 5.3

In plain English

A medium-severity improper input validation in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.3%top 75.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10tomcat1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:9tomcat1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-admin-webapps1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:9tomcat-admin-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-docs-webapp1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:9tomcat-docs-webapp1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:9tomcat-el-3.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-el-5.0-api1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-jsp-3.1-api1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:10tomcat-lib1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:9tomcat-lib1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-servlet-6.0-api1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:10tomcat-webapps1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:9tomcat-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat91:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat91:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-admin-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-admin-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-docs-webapp1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-docs-webapp1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-el-3.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-el-3.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-lib1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-lib1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
Debian:12tomcat1010.1.55-1~deb12u1DEBIAN-CVE-2026-32990
Debian:13tomcat1010.1.55-1~deb13u1DEBIAN-CVE-2026-32990
Debian:14tomcat1010.1.54-1DEBIAN-CVE-2026-32990
Debian:13tomcat1111.0.22-1~deb13u1DEBIAN-CVE-2026-32990
Debian:14tomcat1111.0.21-1DEBIAN-CVE-2026-32990
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-32990
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-32990
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-32990
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.53GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.116GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.20GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat:tomcat11.0.20GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat:tomcat9.0.116GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat:tomcat10.1.53GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat:tomcat-coyote11.0.20GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat:tomcat-coyote10.1.53GHSA-8mc5-53m5-3qj2
Mavenorg.apache.tomcat:tomcat-coyote9.0.116GHSA-8mc5-53m5-3qj2
Rocky Linux:10tomcat1:10.1.49-4.el10_2RLSA-2026:69259
Rocky Linux:9tomcat1:9.0.120-2.el9_8RLSA-2026:68660
Rocky Linux:10tomcat91:9.0.120-1.el10_2RLSA-2026:68651
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-32990
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-32990

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.15 – through 11.0.1910.1.50 – through 10.1.529.0.113 – through 9.0.115

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References