Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M
CVE-2026-32954ERP has a possibility SQL Injection vulnerability due to missing validation
High 7.1
In plain English
A high-severity SQL injection in erpnext from frappe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.3%top 74.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
ERP is a free and open source Enterprise Resource Planning tool. In versions prior to 16.8.0 and 15.100.0, certain endpoints were vulnerable to time-based and boolean-based blind SQL injection due to insufficient parameter validation, allowing attackers to infer database information. This issue has been fixed in versions 15.100.0 and 16.8.0.
Affected products (as reported)
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-j669-ghv2-gmqg x_refsource_CONFIRM
- https://github.com/frappe/erpnext/releases/tag/v15.100.0 x_refsource_MISC
- https://github.com/frappe/erpnext/releases/tag/v16.8.0 x_refsource_MISC