Vulnerability · Published Sep 2, 2026 · Assigned by apache
CVE-2026-32773Apache Spark: XSS Vulnerability in Spark Web 3.5.4
Medium 6.1
In plain English
A medium-severity security flaw in Apache Spark from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.spark:spark-core_2.12 | 3.5.8 | GHSA-9437-39hj-3c93 |
| Maven | org.apache.spark:spark-core_2.13 | 3.5.8 | GHSA-9437-39hj-3c93 |
| PyPI | pyspark | 3.5.8 | GHSA-9437-39hj-3c93 |
| PyPI | pyspark | 3.5.8 | PYSEC-2026-3966 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Spark | 3.0.0 – before 3.5.8 |
Weakness: CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N