Vulnerability · Published Mar 13, 2026 · Assigned by GitHub_M

CVE-2026-32732XSS in @leanprover/unicode-input-component

None 0.0

In plain English

A security flaw in vscode-lean4 from leanprover. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)0.0None
Exploit odds (30 days)0.3%top 75.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Lean 4 VS Code Extension is a Visual Studio Code extension for the Lean 4 proof assistant. Projects that use @leanprover/unicode-input-component are vulnerable to an XSS exploit in 0.1.9 of the package and lower. The component re-inserted text in the input element back into the input element as unescaped HTML. The issue has been resolved in 0.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@leanprover/unicode-input-component0.2.0GHSA-6ggm-pwr9-r5h2

Affected products (as reported)

VendorProductVersions
leanprover vscode-lean4 < 0.2.0

Weakness: CWE-80 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N

References