Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M
CVE-2026-32711pydicom: Path traversal in FileSet/DICOMDIR ReferencedFileID allows file access outside the File-set root
High 7.8
In plain English
A high-severity path traversal in pydicom from pydicom. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pydicom is a pure Python package for working with DICOM files. Versions 2.0.0-rc.1 through 3.0.1 are vulnerable to Path Traversal through a maliciously crafted DICOMDIR ReferencedFileID when it is set to a path outside the File-set root. pydicom resolves the path only to confirm that it exists, but does not verify that the resolved path remains under the File-set root. Subsequent public FileSet operations such as copy(), write(), and remove()+write(use_existing=True) use that unchecked path in file I/O operations. This allows arbitrary file read/copy and, in some flows, move/delete outside the File-set root. This issue has been fixed in version 3.0.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | py3-pydicom | 3.0.2-r0 | ALPINE-CVE-2026-32711 |
| Alpine:v3.24 | py3-pydicom | 3.0.2-r0 | ALPINE-CVE-2026-32711 |
| Debian:12 | pydicom | no fix listed | DEBIAN-CVE-2026-32711 |
| Debian:13 | pydicom | no fix listed | DEBIAN-CVE-2026-32711 |
| Debian:14 | pydicom | 3.0.2-1 | DEBIAN-CVE-2026-32711 |
| PyPI | pydicom | 3.0.2 | PYSEC-2026-2266 |
| PyPI | pydicom | 2.4.5 | GHSA-v856-2rf8-9f28 |
| PyPI | pydicom | 3.0.2 | GHSA-v856-2rf8-9f28 |
| Ubuntu:22.04:LTS | pydicom | no fix listed | UBUNTU-CVE-2026-32711 |
| Ubuntu:24.04:LTS | pydicom | no fix listed | UBUNTU-CVE-2026-32711 |
| Ubuntu:25.10 | pydicom | no fix listed | UBUNTU-CVE-2026-32711 |
| Ubuntu:26.04:LTS | pydicom | no fix listed | UBUNTU-CVE-2026-32711 |
| Ubuntu:26.10 | pydicom | no fix listed | UBUNTU-CVE-2026-32711 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/pydicom/pydicom/security/advisories/GHSA-v856-2rf8-9f28 x_refsource_CONFIRM
- https://github.com/pydicom/pydicom/commit/6414f01a053dff925578799f5a7208d2ae585e82 x_refsource_MISC
- https://github.com/pydicom/pydicom/releases/tag/v3.0.2 x_refsource_MISC