Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M

CVE-2026-32710Heap-based Buffer Overflow in MariaDB

High 8.6

In plain English

A high-severity heap buffer overflow in server from MariaDB. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.9%top 40.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

MariaDB server is a community developed fork of MySQL server. An authenticated user can crash MariaDB versions 11.4 before 11.4.10 and 11.8 before 11.8.6 via a bug in JSON_SCHEMA_VALID() function. Under certain conditions it might be possible to turn the crash into a remote code execution. These conditions require tight control over memory layout which is generally only attainable in a lab environment. This issue is fixed in MariaDB 11.4.10, MariaDB 11.8.6, and MariaDB 12.2.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13mariadb1:11.8.6-0+deb13u1DEBIAN-CVE-2026-32710
Debian:14mariadb1:11.8.6-1DEBIAN-CVE-2026-32710
Rocky Linux:10galera0:26.4.25-1.el10_2RLSA-2026:19021
Rocky Linux:9galera0:26.4.25-1.module+el9.8.0+40192+484cc2deRLSA-2026:19182
Rocky Linux:9mariadb3:11.8.6-2.module+el9.8.0+40192+484cc2deRLSA-2026:19182
Rocky Linux:10mariadb11.83:11.8.6-2.el10_2RLSA-2026:19021
Ubuntu:24.04:LTSmariadbno fix listedUBUNTU-CVE-2026-32710
Ubuntu:25.10mariadbno fix listedUBUNTU-CVE-2026-32710

Affected products (as reported)

VendorProductVersions
MariaDB server >= 11.4.1, < 11.4.10>= 11.8.1, < 11.8.6>= 12.1.2, < 12.2.2

Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

References