Vulnerability · Published Mar 13, 2026 · Assigned by GitHub_M
CVE-2026-32706PX4 autopilot has a global buffer overflow in crsf_rc via oversized variable-length known packet
High 7.1
In plain English
A high-severity buffer overflow in PX4-Autopilot from PX4. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, The crsf_rc parser accepts an oversized variable-length known packet and copies it into a fixed 64-byte global buffer without a bounds check. In deployments where crsf_rc is enabled on a CRSF serial port, an adjacent/raw-serial attacker can trigger memory corruption and crash PX4. This vulnerability is fixed in 1.17.0-rc2.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PX4 | PX4-Autopilot | < 1.17.0-rc2 |
Weakness: CWE-120, CWE-787 · Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
References
- https://github.com/PX4/PX4-Autopilot/security/advisories/GHSA-mqgj-hh4g-fg5p x_refsource_CONFIRM