Vulnerability · Published Mar 18, 2026 · Assigned by GitHub_M

CVE-2026-32700Devise has a confirmable "change email" race condition that permits user to confirm email they have no access to

Medium 6.0

In plain English

A medium-severity race condition in devise from heartcombo. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)0.3%top 78.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Devise is an authentication solution for Rails based on Warden. Prior to version 5.0.3, a race condition in Devise's Confirmable module allows an attacker to confirm an email address they do not own. This affects any Devise application using the `reconfirmable` option (the default when using Confirmable with email changes). By sending two concurrent email change requests, an attacker can desynchronize the `confirmation_token` and `unconfirmed_email` fields. The confirmation token is sent to an email the attacker controls, but the `unconfirmed_email` in the database points to a victim's email address. When the attacker uses the token, the victim's email is confirmed on the attacker's account. This is patched in Devise v5.0.3. Users should upgrade as soon as possible. As a workaround, applications can override a specific method from Devise models to force `unconfirmed_email` to be persisted when unchanged. Note that Mongoid does not seem to respect that `will_change!` should force the attribute to be persisted, even if it did not really change, so the user might have to implement a workaround similar to Devise by setting `changed_attributes["unconfirmed_email"] = nil` as well.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-deviseno fix listedDEBIAN-CVE-2026-32700
RubyGemsdevise5.0.3GHSA-57hq-95w6-v4fc
Ubuntu:22.04:LTSruby-deviseno fix listedUBUNTU-CVE-2026-32700
Ubuntu:24.04:LTSruby-deviseno fix listedUBUNTU-CVE-2026-32700

Affected products (as reported)

VendorProductVersions
heartcombo devise < 5.0.3

Weakness: CWE-362 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References