Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-32619Discourse: Insufficient topic visibility check allows unauthorized poll manipulation in private categories

Medium 6.3

In plain English

A medium-severity security flaw in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities).

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.2%top 94.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, users who lost access to a topic (e.g., removed from a private category group) could still interact with polls in that topic, including voting and toggling poll status. No content was exposed, but users could modify poll state in topics they should no longer have access to. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Affected products (as reported)

VendorProductVersions
discourse discourse >= 2026.1.0-latest, < 2026.1.3>= 2026.2.0-latest, < 2026.2.2>= 2026.3.0-latest, < 2026.3.0

Weakness: CWE-285 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References