Vulnerability · Published Aug 6, 2026 · Assigned by apache

CVE-2026-32327Apache Portable Runtime Utility: apr-util XML stack recursion crash

Critical 9.1

In plain English

A critical-severity security flaw in Apache Portable Runtime Utility from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.5%top 60.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10apr-util1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:8apr-util-bdb1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-bdb1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-devel1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-devel1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-devel1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-ldap1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-ldap1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-ldap1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-lmdb1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:10apr-util-mysql1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-mysql1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-mysql1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-odbc1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-odbc1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-odbc1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-openssl1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-openssl1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-openssl1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-pgsql1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-pgsql1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-pgsql1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-sqlite1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-sqlite1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-sqlite1.6.1-23.el9_8.1ALSA-2026:66341
Alpine:v3.21apr-util1.6.4-r0ALPINE-CVE-2026-32327
Alpine:v3.22apr-util1.6.4-r0ALPINE-CVE-2026-32327
Alpine:v3.23apr-util1.6.4-r0ALPINE-CVE-2026-32327
Alpine:v3.24apr-util1.6.4-r0ALPINE-CVE-2026-32327
Debian:12apr-util1.6.3-1+deb12u1DEBIAN-CVE-2026-32327
Debian:13apr-util1.6.3-3+deb13u1DEBIAN-CVE-2026-32327
Debian:14apr-util1.6.4-1DEBIAN-CVE-2026-32327
Rocky Linux:10apr-util0:1.6.3-23.el10_2.1RLSA-2026:66392
Rocky Linux:8apr-util0:1.6.1-9.el8_10.1RLSA-2026:69113
Rocky Linux:9apr-util0:1.6.1-23.el9_8.1RLSA-2026:66341
Ubuntu:22.04:LTSapr-util1.6.1-5ubuntu4.22.04.3USN-8719-1
Ubuntu:22.04:LTSapr-util1.6.1-5ubuntu4.22.04.3UBUNTU-CVE-2026-32327
Ubuntu:24.04:LTSapr-util1.6.3-1.1ubuntu7.1USN-8719-1
Ubuntu:24.04:LTSapr-util1.6.3-1.1ubuntu7.1UBUNTU-CVE-2026-32327
Ubuntu:26.04:LTSapr-util1.6.3-3ubuntu3.1UBUNTU-CVE-2026-32327
Ubuntu:26.04:LTSapr-util1.6.3-3ubuntu3.1USN-8719-1

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Portable Runtime Utility 0 – through 1.6.3

Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

References