Vulnerability · Published Mar 13, 2026 · Assigned by GitHub_M
CVE-2026-32314Yamux remote Panic via malformed Data frame with SYN set and len = 262145
High 8.7
In plain English
A high-severity security flaw in rust-yamux from libp2p. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. Prior to 0.13.10, the Rust implementation of Yamux can panic when processing a crafted inbound Data frame that sets SYN and uses a body length greater than DEFAULT_CREDIT (e.g. 262145). On the first packet of a new inbound stream, stream state is created and a receiver is queued before oversized-body validation completes. When validation fails, the temporary stream is dropped and cleanup may call remove(...).expect("stream not found"), triggering a panic in the connection state machine. This is remotely reachable over a normal Yamux session and does not require authentication. This vulnerability is fixed in 0.13.10.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | rust-yamux | no fix listed | DEBIAN-CVE-2026-32314 |
| Debian:14 | rust-yamux | 0.13.10+ds-1 | DEBIAN-CVE-2026-32314 |
| Ubuntu:25.10 | rust-yamux | no fix listed | UBUNTU-CVE-2026-32314 |
| Ubuntu:26.04:LTS | rust-yamux | no fix listed | UBUNTU-CVE-2026-32314 |
| Ubuntu:26.10 | rust-yamux | no fix listed | UBUNTU-CVE-2026-32314 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| libp2p | rust-yamux | < 0.13.10 |
Weakness: CWE-248 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/libp2p/rust-yamux/security/advisories/GHSA-vxx9-2994-q338 x_refsource_CONFIRM