Vulnerability · Published Mar 12, 2026 · Assigned by GitHub_M

CVE-2026-32269Parse Server OAuth2 adapter app ID validation sends wrong token to introspection endpoint

Medium 6.3

In plain English

A medium-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.3%top 78.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.13 and 8.6.39, the OAuth2 authentication adapter does not correctly validate app IDs when appidField and appIds are configured. During app ID validation, a malformed value is sent to the token introspection endpoint instead of the user's actual access token. Depending on the introspection endpoint's behavior, this could either cause all OAuth2 logins to fail, or allow authentication from disallowed app contexts if the endpoint returns valid-looking data for the malformed request. Deployments using the OAuth2 adapter with appidField and appIds configured are affected. This vulnerability is fixed in 9.6.0-alpha.13 and 8.6.39.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.6.0-alpha.13GHSA-69xg-f649-w5g2
npmparse-server8.6.39GHSA-69xg-f649-w5g2

Affected products (as reported)

VendorProductVersions
parse-community parse-server >= 9.0.0, < 9.6.0-alpha.13>= 8.0.2, < 8.6.39

Weakness: CWE-683 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References