Vulnerability · Published Mar 18, 2026 · Assigned by GitHub_M
CVE-2026-32266Google Cloud Storage for Craft CMS has an Information Disclosure Vulnerability
Low 2.4
In plain English
A low-severity information exposure in google-cloud from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The Google Cloud Storage for Craft CMS plugin provides a Google Cloud Storage integration for Craft CMS. In versions on the 2.x branch prior to 2.2.1, the `DefaultController->actionLoadBucketData()` endpoint allows unauthenticated users with a valid CSRF token to view a list of buckets that the plugin is allowed to see. Users should update to version 2.2.1 of the plugin to mitigate the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | craftcms/google-cloud | 2.2.1 | GHSA-67cr-jmh8-4jpq |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| craftcms | google-cloud | >= 2.0.0-beta.1, < 2.2.1 |
Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N/E:U