Vulnerability · Published Mar 16, 2026 · Assigned by GitHub_M

CVE-2026-32261RCE via SSTI for users with permissions to access the Craft CMS Webhooks plugin

High 8.5

In plain English

A high-severity security flaw in webhooks from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.5High
Exploit odds (30 days)0.4%top 65.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Webhooks for Craft CMS plugin adds the ability to manage “webhooks” in Craft CMS, which will send GET or POST requests when certain events occur. From version 3.0.0 to before version 3.2.0, the Webhooks plugin renders user-supplied template content through Twig’s renderString() function without sandbox protection. This allows an authenticated user with access to the Craft control panel and permissions to access the Webhooks plugin to inject Twig template code that calls arbitrary PHP functions. This is possible even if allowAdminChanges is set to false. This issue has been patched in version 3.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/webhooks3.2.0GHSA-8wg7-wm29-2rvg

Affected products (as reported)

VendorProductVersions
craftcms webhooks >= 3.0.0, < 3.2.0

Weakness: CWE-1336 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References