Vulnerability · Published Mar 18, 2026 · Assigned by GitHub_M
CVE-2026-31891Cockpit CMS has SQL Injection in MongoLite Aggregation Optimizer via toJsonExtractRaw()
High 7.7
In plain English
A high-severity SQL injection in Cockpit from Cockpit-HQ. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Cockpit is a headless content management system. Any Cockpit CMS instance running version 2.13.4 or earlier with API access enabled is potentially affected by a a SQL Injection vulnerability in the MongoLite Aggregation Optimizer. Any deployment where the `/api/content/aggregate/{model}` endpoint is publicly accessible or reachable by untrusted users may be vulnerable, and attackers in possession of a valid read-only API key (the lowest privilege level) can exploit this vulnerability — no admin access is required. An attacker can inject arbitrary SQL via unsanitized field names in aggregation queries, bypass the `_state=1` published-content filter to access unpublished or restricted content, and extract unauthorized data from the underlying SQLite content database. This vulnerability has been patched in version 2.13.5. The fix applies the same field-name sanitization introduced in v2.13.3 for `toJsonPath()` to the `toJsonExtractRaw()` method in `lib/MongoLite/Aggregation/Optimizer.php`, closing the injection vector in the Aggregation Optimizer.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | cockpit-hq/cockpit | 2.13.5 | GHSA-7x5c-vfhj-9628 |
| Ubuntu:22.04:LTS | cockpit | no fix listed | UBUNTU-CVE-2026-31891 |
| Ubuntu:24.04:LTS | cockpit | no fix listed | UBUNTU-CVE-2026-31891 |
| Ubuntu:25.10 | cockpit | no fix listed | UBUNTU-CVE-2026-31891 |
| Ubuntu:26.04:LTS | cockpit | no fix listed | UBUNTU-CVE-2026-31891 |
| Ubuntu:26.10 | cockpit | no fix listed | UBUNTU-CVE-2026-31891 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Cockpit-HQ | Cockpit | < 2.13.5 |
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
References
- https://github.com/Cockpit-HQ/Cockpit/security/advisories/GHSA-7x5c-vfhj-9628 x_refsource_CONFIRM
- https://github.com/Cockpit-HQ/Cockpit/releases/tag/2.13.5 x_refsource_MISC