Vulnerability · Published Mar 11, 2026 · Assigned by GitHub_M
CVE-2026-31887Shopware unauthenticated data extraction possible through store-api.order endpoint
High 8.9
In plain English
A high-severity incorrect authorization in core from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Shopware is an open commerce platform. Prior to 6.7.8.1 and 6.6.10.15, an insufficient check on the filter types for unauthenticated customers allows access to orders of other customers. This is part of the deepLinkCode support on the store-api.order endpoint. This vulnerability is fixed in 6.7.8.1 and 6.6.10.15.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | shopware/core | 6.7.8.1 | GHSA-7vvp-j573-5584 |
| Packagist | shopware/core | 6.6.10.15 | GHSA-7vvp-j573-5584 |
| Packagist | shopware/platform | 6.7.8.1 | GHSA-7vvp-j573-5584 |
| Packagist | shopware/platform | 6.6.10.15 | GHSA-7vvp-j573-5584 |
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
References
- https://github.com/shopware/shopware/security/advisories/GHSA-7vvp-j573-5584 x_refsource_CONFIRM