Vulnerability · Published Mar 11, 2026 · Assigned by GitHub_M

CVE-2026-31872Parse Server has a protected fields bypass via dot-notation in query and sort

High 8.7

In plain English

A high-severity improper access control in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 63.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.6 and 8.6.32, the protectedFields class-level permission (CLP) can be bypassed using dot-notation in query WHERE clauses and sort parameters. An attacker can use dot-notation to query or sort by sub-fields of a protected field, enabling a binary oracle attack to enumerate protected field values. This affects both MongoDB and PostgreSQL deployments. This vulnerability is fixed in 9.6.0-alpha.6 and 8.6.32.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.6.0-alpha.6GHSA-r2m8-pxm9-9c4g
npmparse-server8.6.32GHSA-r2m8-pxm9-9c4g

Affected products (as reported)

VendorProductVersions
parse-community parse-server >= 9.0.0 < 9.6.0-alpha.6< 8.6.32

Weakness: CWE-284 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References