Vulnerability · Published Mar 11, 2026 · Assigned by GitHub_M

CVE-2026-31857CraftCMS has an RCE vulnerability via relational conditionals in the control panel

High 8.1

In plain English

A high-severity code injection in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.1High
Exploit odds (30 days)0.9%top 39.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Craft is a content management system (CMS). Prior to 5.9.9 and 4.17.4, a Remote Code Execution vulnerability exists in the Craft CMS 5 conditions system. The BaseElementSelectConditionRule::getElementIds() method passes user-controlled string input through renderObjectTemplate() -- an unsandboxed Twig rendering function with escaping disabled. Any authenticated Control Panel user (including non-admin roles such as Author or Editor) can achieve full RCE by sending a crafted condition rule via standard element listing endpoints. This vulnerability requires no admin privileges, no special permissions beyond basic control panel access, and bypasses all production hardening settings (allowAdminChanges: false, devMode: false, enableTwigSandbox: true). Users should update to the patched 5.9.9 or 4.17.4 release to mitigate the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms5.9.9GHSA-fp5j-j7j4-mcxc
Packagistcraftcms/cms4.17.4GHSA-fp5j-j7j4-mcxc

Affected products (as reported)

VendorProductVersions
craftcms cms >= 5.0.0-RC1, < 5.9.9>= 4.0.0-beta.1, < 4.17.4

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References