Vulnerability · Published Mar 11, 2026 · Assigned by GitHub_M

CVE-2026-31856Parse Server has a SQL injection via `Increment` operation on nested object field in PostgreSQL

Critical 9.3

In plain English

A critical-severity SQL injection in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)0.5%top 58.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The amount value is interpolated directly into the SQL query without parameterization or type validation. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL subqueries to read any data from the database, bypassing CLPs and ACLs. MongoDB deployments are not affected. This vulnerability is fixed in 9.6.0-alpha.3 and 8.6.29.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.6.0-alpha.3GHSA-q3vj-96h2-gwvg
npmparse-server8.6.29GHSA-q3vj-96h2-gwvg

Affected products (as reported)

VendorProductVersions
parse-community parse-server >= 9.0.0 < 9.6.0-alpha.3< 8.6.29

Weakness: CWE-89 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References