Vulnerability · Published Mar 12, 2026 · Assigned by GitHub_M
CVE-2026-31841Raw exposure of database statements in Hyperterse MCP search tool
Medium 6.5
In plain English
A medium-severity security flaw in hyperterse from hyperterse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | hyperterse | 2.2.0 | GHSA-92gp-jfgx-9qpv |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| hyperterse | hyperterse | >= 2.0.0, < 2.2.0 |
Weakness: CWE-433 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/hyperterse/hyperterse/security/advisories/GHSA-92gp-jfgx-9qpv x_refsource_CONFIRM
- https://github.com/hyperterse/hyperterse/releases/tag/v2.2.0 x_refsource_MISC