Vulnerability · Published Mar 10, 2026 · Assigned by GitHub_M
CVE-2026-31834Umbraco Affected by Vertical Privilege Escalation via Missing Authorization Checks
High 7.2
In plain English
A high-severity privilege mismanagement in Umbraco-CMS from umbraco. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Umbraco is an ASP.NET CMS. From 15.3.1 to before 16.5.1 and 17.2.2, A privilege escalation vulnerability has been identified in Umbraco CMS. Under certain conditions, authenticated backoffice users with permission to manage users, may be able to elevate their privileges due to insufficient authorization enforcement when modifying user group memberships. The affected functionality does not properly validate whether a user has sufficient privileges to assign highly privileged roles. This vulnerability is fixed in 16.5.1 and 17.2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| NuGet | umbraco.cms | 16.5.1 | GHSA-rhcg-3h8r-v6vp |
| NuGet | umbraco.cms | 17.2.2 | GHSA-rhcg-3h8r-v6vp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| umbraco | Umbraco-CMS | >= 15.3.1, < 16.5.1>= 17.0.0, < 17.2.1 |
Weakness: CWE-269, CWE-284, CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/umbraco/Umbraco-CMS/security/advisories/GHSA-rhcg-3h8r-v6vp x_refsource_CONFIRM