Vulnerability · Published Mar 10, 2026 · Assigned by GitHub_M

CVE-2026-31828Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction

Medium 6.0

In plain English

A medium-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)0.5%top 57.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.5.2-alpha.13GHSA-7m6r-fhh7-r47c
npmparse-server8.6.26GHSA-7m6r-fhh7-r47c

Affected products (as reported)

VendorProductVersions
parse-community parse-server >= 9.0.0 < 9.5.2-alpha.13< 8.6.26

Weakness: CWE-90 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References