Vulnerability · Published Mar 10, 2026 · Assigned by GitHub_M
CVE-2026-31826pypdf: manipulated stream length values can exhaust RAM
Medium 6.8
In plain English
A medium-severity resource allocation without limits in pypdf from py-pdf. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pypdf is a free and open-source pure-python PDF library. Prior to 6.8.0, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing a content stream with a rather large /Length value, regardless of the actual data length inside the stream. This vulnerability is fixed in 6.8.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | pypdf | no fix listed | DEBIAN-CVE-2026-31826 |
| Debian:13 | pypdf | no fix listed | DEBIAN-CVE-2026-31826 |
| Debian:14 | pypdf | 6.9.0-1 | DEBIAN-CVE-2026-31826 |
| Debian:12 | pypdf2 | no fix listed | DEBIAN-CVE-2026-31826 |
| PyPI | pypdf | 6.8.0 | GHSA-hqmh-ppp3-xvm7 |
| PyPI | pypdf | 6.8.0 | PYSEC-2026-3019 |
| Ubuntu:24.04:LTS | pypdf | no fix listed | UBUNTU-CVE-2026-31826 |
| Ubuntu:25.10 | pypdf | no fix listed | UBUNTU-CVE-2026-31826 |
| Ubuntu:26.04:LTS | pypdf | no fix listed | UBUNTU-CVE-2026-31826 |
| Ubuntu:26.10 | pypdf | no fix listed | UBUNTU-CVE-2026-31826 |
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-hqmh-ppp3-xvm7 x_refsource_CONFIRM
- https://github.com/py-pdf/pypdf/pull/3675 x_refsource_MISC
- https://github.com/py-pdf/pypdf/releases/tag/6.8.0 x_refsource_MISC