Vulnerability · Published Mar 13, 2026 · Assigned by GitHub_M

CVE-2026-31814Yamux remote Panic via malformed WindowUpdate credit

High 8.7

In plain English

A high-severity integer overflow in rust-yamux from libp2p. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 58.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. From 0.13.0 to before 0.13.9, a specially crafted WindowUpdate can cause arithmetic overflow in send-window accounting, which triggers a panic in the connection state machine. This is remotely reachable over a normal network connection and does not require authentication. This vulnerability is fixed in 0.13.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13rust-yamuxno fix listedDEBIAN-CVE-2026-31814
Debian:14rust-yamux0.13.9+ds-1DEBIAN-CVE-2026-31814
Ubuntu:25.10rust-yamuxno fix listedUBUNTU-CVE-2026-31814
Ubuntu:26.04:LTSrust-yamuxno fix listedUBUNTU-CVE-2026-31814
Ubuntu:26.10rust-yamuxno fix listedUBUNTU-CVE-2026-31814

Affected products (as reported)

VendorProductVersions
libp2p rust-yamux >= 0.13.0, < 0.13.9

Weakness: CWE-190 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References