Vulnerability · Published Mar 10, 2026 · Assigned by GitHub_M
CVE-2026-30946Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API
High 8.7
In plain English
A high-severity resource allocation without limits in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior 9.5.2-alpha.2 and 8.6.15, an unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. This vulnerability is fixed in 9.5.2-alpha.2 and 8.6.15.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | parse-server | 8.6.15 | GHSA-cmj3-wx7h-ffvg |
| npm | parse-server | 9.5.2-alpha.2 | GHSA-cmj3-wx7h-ffvg |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| parse-community | parse-server | < 8.6.15>= 9.0.0 < 9.5.2-alpha.2 |
Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N