Vulnerability · Published May 5, 2026 · Assigned by GitHub_M

CVE-2026-30923libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings

High 8.2

In plain English

A high-severity out-of-bounds read in ModSecurity from owasp-modsecurity. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 62.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Libmodsecurity is one component of the ModSecurity v3 project. A segmentation fault occurs when a rule using the t:hexDecode transformation inspects a query string parameter containing a single character. An attacker can exploit this to crash worker processes, causing a denial of service. Service resumes once the attack stops as worker processes recover from the segfault. All versions before 3.0.15 of libModSecurity3 are affected. This has been patched in version 3.0.15.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12modsecurity3.0.9-1+deb12u2DEBIAN-CVE-2026-30923
Debian:13modsecurity3.0.14-1+deb13u1DEBIAN-CVE-2026-30923
Debian:14modsecurity3.0.15-1DEBIAN-CVE-2026-30923
Ubuntu:22.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-30923
Ubuntu:24.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-30923
Ubuntu:25.10modsecurityno fix listedUBUNTU-CVE-2026-30923
Ubuntu:26.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-30923
Ubuntu:26.10modsecurityno fix listedUBUNTU-CVE-2026-30923

Affected products (as reported)

VendorProductVersions
owasp-modsecurity ModSecurity < 3.0.15

Weakness: CWE-125 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References