Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M
CVE-2026-30879baserCMS: Cross-site scripting vulnerability in blog post
Medium 6.9
In plain English
A medium-severity cross-site scripting in basercms from baserproject. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.2%top 84.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
baserCMS is a website development framework. Prior to version 5.2.3, baserCMS has a cross-site scripting vulnerability in blog posts. This issue has been patched in version 5.2.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | baserproject/basercms | 5.2.3 | GHSA-jmq3-x8q7-j9qm |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| baserproject | basercms | < 5.2.3 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/baserproject/basercms/security/advisories/GHSA-jmq3-x8q7-j9qm x_refsource_CONFIRM
- https://basercms.net/security/JVN_20837860 x_refsource_MISC
- https://github.com/baserproject/basercms/releases/tag/5.2.3 x_refsource_MISC