Vulnerability · Published Mar 9, 2026 · Assigned by GitHub_M

CVE-2026-30870Some sync filters in PowerSync Service ignored using `config.edition: 3`

Medium 6.5

In plain English

A medium-severity security flaw in service-core from @powersync. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.2%top 85.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PowerSync Service is the server-side component of the PowerSync sync engine. In version 1.20.0, when using new sync streams with config.edition: 3, certain subquery filters were ignored when determining which data to sync to users. Depending on the sync stream configuration, this could result in authenticated users syncing data that should have been restricted. Only queries that gate synchronization using subqueries without partitioning the result set are affected. This vulnerability is fixed in 1.20.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@powersync/service-core1.20.1GHSA-q6wc-xx4m-92fj
npm@powersync/service-sync-rules0.33.0GHSA-q6wc-xx4m-92fj

Affected products (as reported)

VendorProductVersions
powersync-ja powersync-service < 1.20.1
@powersync service-core < 1.20.1
@powersync service-sync-rules < 0.33.0

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References