Vulnerability · Published Mar 7, 2026 · Assigned by GitHub_M
CVE-2026-30851Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation
High 8.1
In plain English
A high-severity improper authentication in caddy from caddyserver. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.3%top 78.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | caddy | 2.11.2-r0 | ALPINE-CVE-2026-30851 |
| Alpine:v3.24 | caddy | 2.11.2-r0 | ALPINE-CVE-2026-30851 |
| Go | github.com/caddyserver/caddy/v2 | 2.11.2 | GO-2026-4639 |
| Go | github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy | 2.11.2 | GHSA-7r4p-vjf4-gxv4 |
| Ubuntu:25.10 | caddy | no fix listed | UBUNTU-CVE-2026-30851 |
| Ubuntu:26.10 | caddy | no fix listed | UBUNTU-CVE-2026-30851 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| caddyserver | caddy | >= 2.10.0, < 2.11.2 |
Weakness: CWE-287, CWE-345 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/caddyserver/caddy/security/advisories/GHSA-7r4p-vjf4-gxv4 x_refsource_CONFIRM
- https://github.com/caddyserver/caddy/issues/6610 x_refsource_MISC
- https://github.com/caddyserver/caddy/pull/6608 x_refsource_MISC
- https://github.com/caddyserver/caddy/pull/7545 x_refsource_MISC