Vulnerability · Published Mar 7, 2026 · Assigned by GitHub_M
CVE-2026-30822Flowise: Mass Assignment in `/api/v1/leads` Endpoint
High 7.7
In plain English
A high-severity security flaw in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 15.0% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.0)7.7High
Exploit odds (30 days)15.0%top 3.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, unauthenticated users can inject arbitrary values into internal database fields when creating leads. This issue has been patched in version 3.0.13.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.0.13 | GHSA-mq4r-h2gh-qv7x |
Affected products (as reported)
Weakness: CWE-915 · Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-mq4r-h2gh-qv7x x_refsource_CONFIRM
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.13 x_refsource_MISC