Vulnerability · Published Mar 7, 2026 · Assigned by GitHub_M

CVE-2026-29195Netmaker: Privilege Escalation from Admin to Super-Admin via User Update

Medium 6.9

In plain English

A medium-severity incorrect authorization in netmaker from gravitl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.3%top 82.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Netmaker makes networks with WireGuard. Prior to version 1.5.0, the user update handler (PUT /api/users/{username}) lacks validation to prevent an admin-role user from assigning the super-admin role during account updates. While the code correctly blocks an admin from assigning the admin role to another user, it does not include an equivalent check for the super-admin role. This issue has been patched in version 1.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/gravitl/netmaker1.5.0GHSA-ch3w-9456-38v3
Gogithub.com/gravitl/netmaker1.5.0GO-2026-4654

Affected products (as reported)

VendorProductVersions
gravitl netmaker < 1.5.0

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References