Vulnerability · Published Mar 7, 2026 · Assigned by GitHub_M

CVE-2026-29194Netmaker: Insufficient Authorization in Host Token Verification

High 8.6

In plain English

A high-severity incorrect authorization in netmaker from gravitl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.5%top 59.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Netmaker makes networks with WireGuard. Prior to version 1.5.0, the Authorize middleware in Netmaker incorrectly validates host JWT tokens. When a route permits host authentication (hostAllowed=true), a valid host token bypasses all subsequent authorization checks without verifying that the host is authorized to access the specific requested resource. Any entity possessing knowledge of object identifiers (node IDs, host IDs) can craft a request with an arbitrary valid host token to access, modify, or delete resources belonging to other hosts. Affected endpoints include node info retrieval, host deletion, MQTT signal transmission, fallback host updates, and failover operations. This issue has been patched in version 1.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/gravitl/netmaker1.5.0GHSA-hmqr-wjmj-376c
Gogithub.com/gravitl/netmaker1.5.0GO-2026-4655

Affected products (as reported)

VendorProductVersions
gravitl netmaker < 1.5.0

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References