Vulnerability · Published Mar 10, 2026 · Assigned by GitHub_M
CVE-2026-29173Craft Commerce has Stored XSS while updating Order Status from Orders Table
Low 1.9
In plain English
A low-severity cross-site scripting in commerce from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, a stored XSS vulnerability exists when a user tries to update the Order Status from the Commerce Orders Table. The Order Status Name is rendered without proper escaping, allowing script execution to occur. This vulnerability is fixed in 4.10.2 and 5.5.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | craftcms/commerce | 4.10.2 | GHSA-mqxf-2998-c6cp |
| Packagist | craftcms/commerce | 5.5.3 | GHSA-mqxf-2998-c6cp |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P