Vulnerability · Published May 11, 2026 · Assigned by apple

CVE-2026-28907

High 8.1

In plain English

A high-severity improper input validation in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.3%top 76.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The issue was addressed with improved input validation. This issue is fixed in Safari 26.5, iOS 18.7.9 and iPadOS 18.7.9, iOS 26.5 and iPadOS 26.5, macOS Tahoe 26.5, tvOS 26.5, visionOS 26.5, watchOS 26.5. Processing maliciously crafted web content may prevent Content Security Policy from being enforced.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.52.4-1.el8_10ALSA-2026:25918
AlmaLinux:9webkit2gtk32.52.4-1.el9_8ALSA-2026:25927
AlmaLinux:8webkit2gtk3-devel2.52.4-1.el8_10ALSA-2026:25918
AlmaLinux:9webkit2gtk3-devel2.52.4-1.el9_8ALSA-2026:25927
AlmaLinux:8webkit2gtk3-jsc2.52.4-1.el8_10ALSA-2026:25918
AlmaLinux:9webkit2gtk3-jsc2.52.4-1.el9_8ALSA-2026:25927
AlmaLinux:8webkit2gtk3-jsc-devel2.52.4-1.el8_10ALSA-2026:25918
AlmaLinux:9webkit2gtk3-jsc-devel2.52.4-1.el9_8ALSA-2026:25927
Debian:12webkit2gtkno fix listedDEBIAN-CVE-2026-28907
Debian:13webkit2gtk2.52.5-1~deb13u1DEBIAN-CVE-2026-28907
Debian:14webkit2gtk2.52.4-1DEBIAN-CVE-2026-28907
Debian:12wpewebkitno fix listedDEBIAN-CVE-2026-28907
Debian:13wpewebkitno fix listedDEBIAN-CVE-2026-28907
Debian:14wpewebkit2.52.4-1DEBIAN-CVE-2026-28907
Rocky Linux:8webkit2gtk30:2.52.4-1.el8_10RLSA-2026:25918
Rocky Linux:9webkit2gtk30:2.52.4-1.el9_8RLSA-2026:25927
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2026-28907
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2026-28907
Ubuntu:22.04:LTSwebkit2gtkno fix listedUBUNTU-CVE-2026-28907
Ubuntu:24.04:LTSwebkit2gtk2.52.6-0ubuntu0.24.04.1USN-8703-1
Ubuntu:24.04:LTSwebkit2gtk2.52.6-0ubuntu0.24.04.1UBUNTU-CVE-2026-28907
Ubuntu:26.04:LTSwebkit2gtk2.52.6-0ubuntu0.26.04.1USN-8703-1
Ubuntu:26.04:LTSwebkit2gtk2.52.6-0ubuntu0.26.04.1UBUNTU-CVE-2026-28907
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2026-28907

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 26.5
Apple iOS and iPadOS 0 – before 18.7.90 – before 26.5
Apple macOS 0 – before 26.5
Apple tvOS 0 – before 26.5
Apple visionOS 0 – before 26.5
Apple watchOS 0 – before 26.5

Weakness: CWE-116, CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References