Vulnerability · Published Feb 27, 2026 · Assigned by GitHub_M
CVE-2026-28426Statamic vulnerable to privilege escalation via stored cross-site scripting
High 8.7
In plain English
A high-severity cross-site scripting in cms from statamic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.11 and 6.4.0, stored XSS vulnerability in svg and icon related components allow authenticated users with appropriate permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. This has been fixed in 5.73.11 and 6.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | statamic/cms | 5.73.11 | GHSA-5vrj-wf7v-5wr7 |
| Packagist | statamic/cms | 6.4.0 | GHSA-5vrj-wf7v-5wr7 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/statamic/cms/security/advisories/GHSA-5vrj-wf7v-5wr7 x_refsource_CONFIRM
- https://github.com/statamic/cms/releases/tag/v5.73.11 x_refsource_MISC
- https://github.com/statamic/cms/releases/tag/v6.4.0 x_refsource_MISC