Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M

CVE-2026-28214Firebird server hangs when using specific clumplet on batch creation

Medium 6.0

In plain English

A medium-severity integer overflow in firebird from FirebirdSQL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)1.1%top 33.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, the ClumpletReader::getClumpletSize() function can overflow the totalLength value when parsing a Wide type clumplet, causing an infinite loop. An authenticated user with INSERT privileges on any table can exploit this via a crafted Batch Parameter Block to cause a denial of service against the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12firebird3.0no fix listedDEBIAN-CVE-2026-28214
Debian:13firebird3.0no fix listedDEBIAN-CVE-2026-28214
Debian:14firebird3.03.0.14.ds7-1DEBIAN-CVE-2026-28214
Debian:13firebird4.0no fix listedDEBIAN-CVE-2026-28214
Debian:14firebird4.04.0.7.3271.ds6-1DEBIAN-CVE-2026-28214
Ubuntu:22.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-28214
Ubuntu:24.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-28214
Ubuntu:25.10firebird3.0no fix listedUBUNTU-CVE-2026-28214
Ubuntu:26.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-28214
Ubuntu:26.10firebird3.0no fix listedUBUNTU-CVE-2026-28214
Ubuntu:25.10firebird4.0no fix listedUBUNTU-CVE-2026-28214
Ubuntu:26.04:LTSfirebird4.0no fix listedUBUNTU-CVE-2026-28214
Ubuntu:26.10firebird4.0no fix listedUBUNTU-CVE-2026-28214

Affected products (as reported)

VendorProductVersions
FirebirdSQL firebird >= 3.0.0, < 3.0.14>= 4.0.0, < 4.0.7>= 5.0.0, < 5.0.4

Weakness: CWE-190, CWE-835 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L

References