Vulnerability · Published Apr 21, 2026 · Assigned by GitHub_M
CVE-2026-27937October: Reflected XSS via DataTable Form Widget
Low 3.1
In plain English
A low-severity cross-site scripting in october from octobercms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
October is a Content Management System (CMS) and web platform. Prior to 3.7.16 and 4.1.16, a reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping. This vulnerability is fixed in 3.7.16 and 4.1.16.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | october/system | 3.7.16 | GHSA-jj38-h5w5-mvpf |
| Packagist | october/system | no fix listed | GHSA-jj38-h5w5-mvpf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| octobercms | october | >= 4.0.0, < 4.1.16< 3.7.16 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
References
- https://github.com/octobercms/october/security/advisories/GHSA-jj38-h5w5-mvpf x_refsource_CONFIRM