Vulnerability · Published Feb 25, 2026 · Assigned by GitHub_M
CVE-2026-27597@enclave-vm/core is vulnerable to Sandbox Escape
Critical 10.0
In plain English
A critical-severity code injection in enclave from agentfront. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Enclave is a secure JavaScript sandbox designed for safe AI agent code execution. Prior to version 2.11.1, it is possible to escape the security boundraries set by `@enclave-vm/core`, which can be used to achieve remote code execution (RCE). The issue has been fixed in version 2.11.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @enclave-vm/core | 2.11.1 | GHSA-f229-3862-4942 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| agentfront | enclave | < 2.11.1 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H