Vulnerability · Published Feb 25, 2026 · Assigned by GitHub_M

CVE-2026-27497n8n has Potential Remote Code Execution via Merge Node

Critical 9.4

In plain English

A critical-severity code injection in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.4Critical
Exploit odds (30 days)0.9%top 40.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, an authenticated user with permission to create or modify workflows could leverage the Merge node's SQL query mode to execute arbitrary code and write arbitrary files on the n8n server. The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmn8n1.123.22GHSA-wxx7-mcgf-j869
npmn8n2.9.3GHSA-wxx7-mcgf-j869
npmn8n2.10.1GHSA-wxx7-mcgf-j869

Affected products (as reported)

VendorProductVersions
n8n-io n8n < 1.123.22>= 2.0.0, < 2.9.3>= 2.10.0, < 2.10.1

Weakness: CWE-94, CWE-89 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References