Vulnerability · Published Mar 25, 2026 · Assigned by GitHub_M

CVE-2026-27496n8n has In-Process Memory Disclosure in its Task Runner

High 7.1

In plain English

A high-severity security flaw in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.3%top 80.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

n8n is an open source workflow automation platform. Prior to versions 1.123.22, 2.9.3, and 2.10.1, an authenticated user with permission to create or modify workflows could use the JavaScript Task Runner to allocate uninitialized memory buffers. Uninitialized buffers may contain residual data from the same Node.js process — including data from prior requests, tasks, secrets, or tokens — resulting in information disclosure of sensitive in-process data. Task Runners must be enabled using `N8N_RUNNERS_ENABLED=true`. In external runner mode, the impact is limited to data within the external runner process. The issue has been fixed in n8n versions 1.123.22, 2.10.1 , and 2.9.3. Users should upgrade to this version or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or use external runner mode (`N8N_RUNNERS_MODE=external`) to isolate the runner process. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmn8n1.123.22GHSA-xvh5-5qg4-x9qp
npmn8n2.10.1GHSA-xvh5-5qg4-x9qp
npmn8n2.9.3GHSA-xvh5-5qg4-x9qp

Affected products (as reported)

VendorProductVersions
n8n-io n8n < 1.123.22>= 2.0.0-rc.0, < 2.9.3>= 2.10.0, < 2.10.1

Weakness: CWE-908 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References