Vulnerability · Published Feb 20, 2026 · Assigned by GitHub_M

CVE-2026-27121Svelte affected by cross-site scripting via spread attributes in Svelte SSR

Medium 5.1

In plain English

A medium-severity cross-site scripting in svelte from sveltejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)0.2%top 87.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

svelte performance oriented web framework. Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. This vulnerability is fixed in 5.51.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmsvelte5.51.5GHSA-f7gr-6p89-r883

Affected products (as reported)

VendorProductVersions
sveltejs svelte < 5.51.5

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:N

References