Vulnerability · Published May 19, 2026 · Assigned by @huntr_ai

CVE-2026-2611Improper Origin Validation in mlflow/mlflow

Critical 9.6

In plain English

A critical-severity security flaw in mlflow/mlflow from mlflow. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.6Critical
Exploit odds (30 days)0.4%top 67.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPImlflow3.10.0GHSA-67c5-x5mf-rppq
PyPImlflow3.10.0PYSEC-2026-418

Affected products (as reported)

VendorProductVersions
mlflow mlflow/mlflow unspecified – before 3.10.0

Weakness: CWE-346, CWE-940 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

References