Vulnerability · Published Feb 20, 2026 · Assigned by GitHub_M
CVE-2026-26065calibre: Path Traversal can Lead to Arbitrary File Write and Potential Code Execution
Critical 9.3
In plain English
A critical-severity path traversal in calibre from kovidgoyal. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
calibre is a cross-platform e-book manager for viewing, converting, editing, and cataloging e-books. Versions 9.2.1 and below are vulnerable to Path Traversal through PDB readers (both 132-byte and 202-byte header variants) that allow arbitrary file writes with arbitrary extension and arbitrary content anywhere the user has write permissions. Files are written in 'wb' mode, silently overwriting existing files. This can lead to potential code execution and Denial of Service through file corruption. This issue has been fixed in version 9.3.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | calibre | 6.13.0+repack-2+deb12u6 | DEBIAN-CVE-2026-26065 |
| Debian:13 | calibre | 8.5.0+ds-1+deb13u2 | DEBIAN-CVE-2026-26065 |
| Debian:14 | calibre | 9.3.0+ds+~0.10.5-1 | DEBIAN-CVE-2026-26065 |
| Ubuntu:22.04:LTS | calibre | no fix listed | UBUNTU-CVE-2026-26065 |
| Ubuntu:24.04:LTS | calibre | no fix listed | UBUNTU-CVE-2026-26065 |
| Ubuntu:25.10 | calibre | no fix listed | UBUNTU-CVE-2026-26065 |
| Ubuntu:26.04:LTS | calibre | no fix listed | UBUNTU-CVE-2026-26065 |
| Ubuntu:26.10 | calibre | no fix listed | UBUNTU-CVE-2026-26065 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| kovidgoyal | calibre | < 9.3.0 |
Weakness: CWE-22 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H