Vulnerability · Published Feb 19, 2026 · Assigned by GitHub_M
CVE-2026-26063CediPay Affected by Improper Input Validation in Payment Processing
High 8.8
In plain English
A high-severity improper input validation in CediPay from xpertforextradeinc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CediPay is a crypto-to-fiat app for the Ghanaian market. A vulnerability in CediPay prior to version 1.2.3 allows attackers to bypass input validation in the transaction API. The issue has been fixed in version 1.2.3. If upgrading is not immediately possible, restrict API access to trusted networks or IP ranges; enforce strict input validation at the application layer; and/or monitor transaction logs for anomalies or suspicious activity. These mitigations reduce exposure but do not fully eliminate the vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | cedipay-core | 1.2.3 | GHSA-wvr6-395c-5pxr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xpertforextradeinc | CediPay | < 1.2.3 |
Weakness: CWE-20 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N