Vulnerability · Published Feb 20, 2026 · Assigned by GitHub_M

CVE-2026-25896fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names

Critical 9.3

In plain English

A critical-severity cross-site scripting in fast-xml-parser from NaturalIntelligence. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.3Critical
Exploit odds (30 days)0.5%top 55.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. From 4.1.3to before 5.3.5, a dot (.) in a DOCTYPE entity name is treated as a regex wildcard during entity replacement, allowing an attacker to shadow built-in XML entities (<, >, &, ", ') with arbitrary values. This bypasses entity encoding and leads to XSS when parsed output is rendered. This vulnerability is fixed in 5.3.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-webfontno fix listedDEBIAN-CVE-2026-25896
Debian:13node-webfontno fix listedDEBIAN-CVE-2026-25896
Debian:14node-webfontno fix listedDEBIAN-CVE-2026-25896
Ubuntu:24.04:LTSnode-webfontno fix listedUBUNTU-CVE-2026-25896
Ubuntu:25.10node-webfontno fix listedUBUNTU-CVE-2026-25896
Ubuntu:26.04:LTSnode-webfontno fix listedUBUNTU-CVE-2026-25896
Ubuntu:26.10node-webfontno fix listedUBUNTU-CVE-2026-25896
npmfast-xml-parser4.5.4GHSA-m7jm-9gc2-mpf2
npmfast-xml-parser5.3.5GHSA-m7jm-9gc2-mpf2

Affected products (as reported)

VendorProductVersions
NaturalIntelligence fast-xml-parser >= 5.0.0, < 5.3.5>= 4.1.3, < 4.5.4

Weakness: CWE-185, CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:N

References