Vulnerability · Published Feb 9, 2026 · Assigned by GitHub_M
CVE-2026-25892Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint
High 7.5
In plain English
A high-severity improper input validation in adminer from vrana. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.
Official description
Adminer is open-source database management software. Adminer v5.4.1 and earlier has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, openssl_verify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Upgrade to Adminer 5.4.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | vrana/adminer | 5.4.2 | GHSA-q4f2-39gr-45jh |
| Ubuntu:22.04:LTS | adminer | no fix listed | UBUNTU-CVE-2026-25892 |
| Ubuntu:24.04:LTS | adminer | no fix listed | UBUNTU-CVE-2026-25892 |
| Ubuntu:25.10 | adminer | no fix listed | UBUNTU-CVE-2026-25892 |
| Ubuntu:26.04:LTS | adminer | no fix listed | UBUNTU-CVE-2026-25892 |
| Ubuntu:26.10 | adminer | no fix listed | UBUNTU-CVE-2026-25892 |
Affected products (as reported)
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/vrana/adminer/security/advisories/GHSA-q4f2-39gr-45jh x_refsource_CONFIRM
- https://github.com/vrana/adminer/commit/21d3a3150388677b18647d68aec93b7850e457d3 x_refsource_MISC
- https://github.com/vrana/adminer/releases/tag/v5.4.2 x_refsource_MISC