Vulnerability · Published Feb 6, 2026 · Assigned by GitHub_M

CVE-2026-25804Antrea has invalid enforcement order for network policy rules caused by integer overflow

High 8.0

In plain English

A high-severity improper authentication in antrea from antrea-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.0High
Exploit odds (30 days)0.5%top 57.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Antrea is a Kubernetes networking solution intended to be Kubernetes native. Prior to versions 2.3.2 and 2.4.3, Antrea's network policy priority assignment system has a uint16 arithmetic overflow bug that causes incorrect OpenFlow priority calculations when handling a large numbers of policies with various priority values. This results in potentially incorrect traffic enforcement. This issue has been patched in versions 2.4.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Goantrea.io/antrea2.3.2GHSA-86x4-wp9f-wrr9
Goantrea.io/antrea2.4.3GHSA-86x4-wp9f-wrr9
Goantrea.io/antreano fix listedGO-2026-4461

Affected products (as reported)

VendorProductVersions
antrea-io antrea < 2.3.2>= 2.4.0, < 2.4.3

Weakness: CWE-287, CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:U

References