Vulnerability · Published Feb 12, 2026 · Assigned by GitHub_M
CVE-2026-25767LavinMQ has incomplete shovel configuration validation
High 8.6
In plain English
A high-severity incorrect authorization in lavinmq from cloudamqp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities).
Official description
LavinMQ is a high-performance message queue & streaming server. Before 2.6.8, an authenticated user, with the “Policymaker” tag, could create shovels bypassing access controls. an authenticated user with the "Policymaker" management tag could exploit it to read messages from vhosts they are not authorized to access or publish messages to vhosts they are not authorized to access. This vulnerability is fixed in 2.6.8.
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/cloudamqp/lavinmq/security/advisories/GHSA-wh37-6vrr-r9wg x_refsource_CONFIRM
- https://github.com/cloudamqp/lavinmq/pull/1670 x_refsource_MISC
- https://github.com/cloudamqp/lavinmq/pull/1687 x_refsource_MISC
- https://github.com/cloudamqp/lavinmq/commit/3a83e5894495b60c7c32a79c3dbc9bd9fa237d9a x_refsource_MISC
- https://github.com/cloudamqp/lavinmq/commit/be03da31f3db1a2552f7094ff58e953ef50cdc82 x_refsource_MISC