Vulnerability · Published Feb 11, 2026 · Assigned by GitHub_M
CVE-2026-25759Statmatic affected by privilege escalation via stored cross-site scripting
High 8.7
In plain English
A high-severity cross-site scripting in cms from statamic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Statmatic is a Laravel and Git powered content management system (CMS). From 6.0.0 to before 6.2.3, a stored XSS vulnerability in content titles allows authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. Malicious user must have an account with control panel access and content creation permissions. This vulnerability can be exploited to allow super admin accounts to be created. This has been fixed in 6.2.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | statamic/cms | 6.2.3 | GHSA-ff9r-ww9c-43x8 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/statamic/cms/security/advisories/GHSA-ff9r-ww9c-43x8 x_refsource_CONFIRM
- https://github.com/statamic/cms/commit/6ed4f65f3387686d6dbd816e9b4f18a8d9736ff6 x_refsource_MISC
- https://github.com/statamic/cms/releases/tag/v6.2.3 x_refsource_MISC