Vulnerability · Published Feb 23, 2026 · Assigned by apache

CVE-2026-25747Apache Camel LevelDB: Deserialization of Untrusted Data in Camel LevelDB

High 8.8

In plain English

A high-severity unsafe deserialization in Apache Camel LevelDB from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.3%top 30.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component. The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0. Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.camel:camel-leveldb4.10.9GHSA-429q-mrc4-38fr
Mavenorg.apache.camel:camel-leveldb4.14.5GHSA-429q-mrc4-38fr
Mavenorg.apache.camel:camel-leveldb4.18.0GHSA-429q-mrc4-38fr

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Camel LevelDB 3.0.0 – before 4.10.94.14.0 – before 4.14.54.15.0 – before 4.18.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References